Netgear Releases FW 1.0.9.60_10.2.60 for R7000 Router; Fixes Bugs with FW v.1.0.9.58_10.2.58

Netgear officially released firmware version 1.0.9.60_10.2.60 late Tuesday to fix bugs with previously released and now removed firmware version 1.0.9.58_10.2.58. Earlier on Tuesday, the new firmware version 1.0.9.60_10.2.60 was available for download directly through the Netgear R7000 admin console; however, no release notes nor related documentation were available through the admin console or on the Netgear support website at the time.

Netgear has now provided release notes on firmware version 1.0.9.60_10.2.60 as well as made the download link available on the Netgear support website. According to Netgear, firmware version 1.0.9.60_10.2.60 includes the following bug fixes:

  • Fixes the issue where the WiFi performance drops

  • Improves the WAN throughput when the traffic meter is enabled

  • Fixes the attached device list issue where devices disappear from the list and cannot be edited in the GUI or Nighthawk app

  • Fixes some security issues

  • Fixes the installation wizard for AP mode.

  • Fixes the issue where the wrong connection type displays in the Access Control page

  • Fixes the issue where the speed test results always shows “0”

  • Fixes the issue where the BASIC page does not display the correct WiFi password when the security mode is in Enterprise mode

  • Fixes the issue where the same network names can be used for the main and guest 2.4 GHz or 5 GHz networks.

  • Fixes the issue where WPS still works even if the WiFi radio is disabled

  • Fixes the potential out of memory issue

If you’ve been experiencing issues after installing firmware version 1.0.9.58_10.2.58 on a Netgear R7000 router, try upgrading to firmware version 1.0.9.60_10.2.60 to see if it resolves your issues.

From my own experience, after upgrading to firmware version 1.0.9.58_10.2.58, I noticed issues including devices losing or dropping the connection to the 5G wireless network, unable to detect the 5G wireless network SSID, latency or loss of connectivity over the 5G wireless network, sporadic or intermittent connectivity issues over the wired network and spontaneous reboot of the Netgear R7000 router. The issues were occurring multiple times daily and seemingly getting worse.

Since upgrading to the new firmware version 1.0.9.60_10.2.60, the Netgear R7000 has been stable and operating normally. Granted, it’s only been slightly over a day since I’ve installed the new firmware, but it looks promising. Fingers crossed!